
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
63 lines
2.3 KiB
Diff
63 lines
2.3 KiB
Diff
From 461aa98f7ee6d5347625728949d51122ee92999b Mon Sep 17 00:00:00 2001
|
|
From: Jernej Skrabec <jernej.skrabec@siol.net>
|
|
Date: Thu, 9 Aug 2018 18:52:14 +0200
|
|
Subject: [PATCH 084/146] clk: sunxi-ng: h3/h5: Add max. rate constraint to
|
|
pll-video
|
|
|
|
As it turns out, pll-video can be set to higher rate that it is really
|
|
supported by HW.
|
|
|
|
For example, one monitor requested 185.58 MHz pixel clock. Clock
|
|
framework calculated that minimum rate error would be when pll-video
|
|
is set to 2040 MHz. This is clearly out of specs.
|
|
|
|
Both H3 and H5 user manuals specify 600 MHz as maximum supported rate.
|
|
However, BSP clock drivers allow up to 912 MHz and 1008 MHz
|
|
respectively. Here 912 MHz is chosen because user manuals were already
|
|
proven wrong once for lower limits.
|
|
|
|
Signed-off-by: Jernej Skrabec <jernej.skrabec@siol.net>
|
|
Signed-off-by: Maxime Ripard <maxime.ripard@bootlin.com>
|
|
---
|
|
drivers/clk/sunxi-ng/ccu-sun8i-h3.c | 25 +++++++++++++------------
|
|
1 file changed, 13 insertions(+), 12 deletions(-)
|
|
|
|
diff --git a/drivers/clk/sunxi-ng/ccu-sun8i-h3.c b/drivers/clk/sunxi-ng/ccu-sun8i-h3.c
|
|
index 77ed0b0ba681..eb5c608428fa 100644
|
|
--- a/drivers/clk/sunxi-ng/ccu-sun8i-h3.c
|
|
+++ b/drivers/clk/sunxi-ng/ccu-sun8i-h3.c
|
|
@@ -69,18 +69,19 @@ static SUNXI_CCU_NM_WITH_SDM_GATE_LOCK(pll_audio_base_clk, "pll-audio-base",
|
|
BIT(28), /* lock */
|
|
CLK_SET_RATE_UNGATE);
|
|
|
|
-static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK_MIN(pll_video_clk, "pll-video",
|
|
- "osc24M", 0x0010,
|
|
- 192000000, /* Minimum rate */
|
|
- 8, 7, /* N */
|
|
- 0, 4, /* M */
|
|
- BIT(24), /* frac enable */
|
|
- BIT(25), /* frac select */
|
|
- 270000000, /* frac rate 0 */
|
|
- 297000000, /* frac rate 1 */
|
|
- BIT(31), /* gate */
|
|
- BIT(28), /* lock */
|
|
- CLK_SET_RATE_UNGATE);
|
|
+static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK_MIN_MAX(pll_video_clk, "pll-video",
|
|
+ "osc24M", 0x0010,
|
|
+ 192000000, /* Minimum rate */
|
|
+ 912000000, /* Maximum rate */
|
|
+ 8, 7, /* N */
|
|
+ 0, 4, /* M */
|
|
+ BIT(24), /* frac enable */
|
|
+ BIT(25), /* frac select */
|
|
+ 270000000, /* frac rate 0 */
|
|
+ 297000000, /* frac rate 1 */
|
|
+ BIT(31), /* gate */
|
|
+ BIT(28), /* lock */
|
|
+ CLK_SET_RATE_UNGATE);
|
|
|
|
static SUNXI_CCU_NM_WITH_FRAC_GATE_LOCK(pll_ve_clk, "pll-ve",
|
|
"osc24M", 0x0018,
|
|
--
|
|
2.17.1
|
|
|