
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
27 lines
924 B
Diff
27 lines
924 B
Diff
From 3785d95f0a1735e427c3ddf6c5f49545ff7559e9 Mon Sep 17 00:00:00 2001
|
|
From: Qiang Yu <yuq825@gmail.com>
|
|
Date: Sun, 15 Jul 2018 12:26:26 +0800
|
|
Subject: [PATCH 077/146] drm/lima: port to 4.18 kernel
|
|
|
|
Signed-off-by: Qiang Yu <yuq825@gmail.com>
|
|
---
|
|
drivers/gpu/drm/lima/lima_sched.c | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
diff --git a/drivers/gpu/drm/lima/lima_sched.c b/drivers/gpu/drm/lima/lima_sched.c
|
|
index e725e793a668..1e715e58d33b 100644
|
|
--- a/drivers/gpu/drm/lima/lima_sched.c
|
|
+++ b/drivers/gpu/drm/lima/lima_sched.c
|
|
@@ -169,8 +169,7 @@ int lima_sched_context_init(struct lima_sched_pipe *pipe,
|
|
return -ENOMEM;
|
|
|
|
mutex_init(&context->lock);
|
|
- err = drm_sched_entity_init(&pipe->base, &context->base, rq,
|
|
- lima_sched_max_tasks, guilty);
|
|
+ err = drm_sched_entity_init(&pipe->base, &context->base, rq, guilty);
|
|
if (err) {
|
|
kfree(context->fences);
|
|
context->fences = NULL;
|
|
--
|
|
2.17.1
|
|
|