
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
33 lines
930 B
Diff
33 lines
930 B
Diff
From c578aadd5ccfe5c64f628ef3aa8c7ff88600e421 Mon Sep 17 00:00:00 2001
|
|
From: Qiang Yu <yuq825@gmail.com>
|
|
Date: Tue, 19 Jun 2018 13:51:17 +0800
|
|
Subject: [PATCH 072/146] drm/fourcc: add ARM tiled format modifier
|
|
|
|
Signed-off-by: Qiang Yu <yuq825@gmail.com>
|
|
---
|
|
include/uapi/drm/drm_fourcc.h | 9 +++++++++
|
|
1 file changed, 9 insertions(+)
|
|
|
|
diff --git a/include/uapi/drm/drm_fourcc.h b/include/uapi/drm/drm_fourcc.h
|
|
index 721ab7e54d96..097d9faca608 100644
|
|
--- a/include/uapi/drm/drm_fourcc.h
|
|
+++ b/include/uapi/drm/drm_fourcc.h
|
|
@@ -581,6 +581,15 @@ extern "C" {
|
|
*/
|
|
#define AFBC_FORMAT_MOD_SC (1ULL << 9)
|
|
|
|
+/*
|
|
+ * ARM tiled format
|
|
+ *
|
|
+ * This is used by ARM Mali Utgard/Midgard GPU. It divides buffer into
|
|
+ * 16x16 pixel blocks. Blocks are stored linearly in order, but pixels
|
|
+ * in the block are reordered.
|
|
+ */
|
|
+#define DRM_FORMAT_MOD_ARM_TILED fourcc_mod_code(ARM, 1)
|
|
+
|
|
#if defined(__cplusplus)
|
|
}
|
|
#endif
|
|
--
|
|
2.17.1
|
|
|