
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
30 lines
993 B
Diff
30 lines
993 B
Diff
From 6d3f37068bbfac21355642148a182c125eb28d19 Mon Sep 17 00:00:00 2001
|
|
From: Qiang Yu <yuq825@gmail.com>
|
|
Date: Thu, 24 May 2018 14:22:03 +0800
|
|
Subject: [PATCH 064/146] drm/lima: Kconfig only depend on ARM or ARM64
|
|
|
|
The depend list gets longer and longer. When adding
|
|
ARCH_ZYNQMP I decide to just depend on ARM or ARM64
|
|
as this GPU can be seen on many ARM SoCs.
|
|
|
|
Signed-off-by: Qiang Yu <yuq825@gmail.com>
|
|
---
|
|
drivers/gpu/drm/lima/Kconfig | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/drivers/gpu/drm/lima/Kconfig b/drivers/gpu/drm/lima/Kconfig
|
|
index 7256625aee04..870f66f407b8 100644
|
|
--- a/drivers/gpu/drm/lima/Kconfig
|
|
+++ b/drivers/gpu/drm/lima/Kconfig
|
|
@@ -4,7 +4,7 @@
|
|
config DRM_LIMA
|
|
tristate "LIMA (DRM support for ARM Mali 400/450 GPU)"
|
|
depends on DRM
|
|
- depends on ARCH_SUNXI || ARCH_ROCKCHIP || ARCH_EXYNOS || ARCH_MESON
|
|
+ depends on ARM || ARM64 || COMPILE_TEST
|
|
select DRM_SCHED
|
|
select DRM_TTM
|
|
help
|
|
--
|
|
2.17.1
|
|
|