
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
54 lines
1.4 KiB
Diff
54 lines
1.4 KiB
Diff
From 559d5cc47ffd71a47da77424e251a8d21250cabb Mon Sep 17 00:00:00 2001
|
|
From: Philipp Rossak <embed3d@gmail.com>
|
|
Date: Sat, 27 Jan 2018 21:39:09 +0100
|
|
Subject: [PATCH 033/146] arm: dts: sun9i: a80: add thermal zone to A80
|
|
|
|
This patch adds the thermal zones to the A80.
|
|
|
|
Sensor 0 is located besides the big CPU, sensor 1 is located besides the
|
|
DRAM, sensor 2 is located besides the GPU and sensor 3 is located besides
|
|
the small CPU.
|
|
|
|
Signed-off-by: Philipp Rossak <embed3d@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/sun9i-a80.dtsi | 26 ++++++++++++++++++++++++++
|
|
1 file changed, 26 insertions(+)
|
|
|
|
diff --git a/arch/arm/boot/dts/sun9i-a80.dtsi b/arch/arm/boot/dts/sun9i-a80.dtsi
|
|
index 9411831d04aa..6c52b33dad84 100644
|
|
--- a/arch/arm/boot/dts/sun9i-a80.dtsi
|
|
+++ b/arch/arm/boot/dts/sun9i-a80.dtsi
|
|
@@ -1221,4 +1221,30 @@
|
|
#size-cells = <0>;
|
|
};
|
|
};
|
|
+
|
|
+ thermal-zones {
|
|
+ cpu0_thermal: cpu0-thermal {
|
|
+ polling-delay-passive = <1000>;
|
|
+ polling-delay = <5000>;
|
|
+ thermal-sensors = <&ths 0>;
|
|
+ };
|
|
+
|
|
+ dram_thermal: dram-thermal {
|
|
+ polling-delay-passive = <1000>;
|
|
+ polling-delay = <5000>;
|
|
+ thermal-sensors = <&ths 1>;
|
|
+ };
|
|
+
|
|
+ gpu_thermal: gpu-thermal {
|
|
+ polling-delay-passive = <1000>;
|
|
+ polling-delay = <5000>;
|
|
+ thermal-sensors = <&ths 2>;
|
|
+ };
|
|
+
|
|
+ cpu2_thermal: cpu2-thermal {
|
|
+ polling-delay-passive = <1000>;
|
|
+ polling-delay = <5000>;
|
|
+ thermal-sensors = <&ths 3>;
|
|
+ };
|
|
+ };
|
|
};
|
|
--
|
|
2.17.1
|
|
|