
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
79 lines
2.5 KiB
Diff
79 lines
2.5 KiB
Diff
From 46f1130b5286457e519c296a4b683747deb983cb Mon Sep 17 00:00:00 2001
|
|
From: Philipp Rossak <embed3d@gmail.com>
|
|
Date: Wed, 24 Jan 2018 16:58:30 +0100
|
|
Subject: [PATCH 027/146] iio: adc: sun4i-gpadc-iio: add support for H5 thermal
|
|
sensor
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
This patch adds support for the H5 ths sensor.
|
|
|
|
The H5 supports interrupts. The interrupt is configured to update
|
|
the sensor values every second. The sensor is except the scale/offset
|
|
values and an additional sensor for the gpu the same. A temperatur higer
|
|
than 70°C needs an other formula. Since the operating temperatures maximum
|
|
is 70°C this case was neglegted.
|
|
|
|
Signed-off-by: Philipp Rossak <embed3d@gmail.com>
|
|
---
|
|
drivers/iio/adc/sun4i-gpadc-iio.c | 36 +++++++++++++++++++++++++++++++
|
|
1 file changed, 36 insertions(+)
|
|
|
|
diff --git a/drivers/iio/adc/sun4i-gpadc-iio.c b/drivers/iio/adc/sun4i-gpadc-iio.c
|
|
index b8693afcdbea..40529a197335 100644
|
|
--- a/drivers/iio/adc/sun4i-gpadc-iio.c
|
|
+++ b/drivers/iio/adc/sun4i-gpadc-iio.c
|
|
@@ -204,6 +204,38 @@ static const struct gpadc_data sun8i_a83t_ths_data = {
|
|
SUNXI_THS_TEMP_PERIOD(0x257),
|
|
};
|
|
|
|
+static const struct gpadc_data sun50i_h5_ths_data = {
|
|
+ .temp_offset = -1872,
|
|
+ .temp_scale = -119,
|
|
+ .temp_data = {SUNXI_THS_TDATA0,
|
|
+ SUNXI_THS_TDATA1, 0, 0},
|
|
+ .sample_start = sunxi_ths_sample_start,
|
|
+ .sample_end = sunxi_ths_sample_end,
|
|
+ .has_bus_clk = true,
|
|
+ .has_bus_rst = true,
|
|
+ .has_mod_clk = true,
|
|
+ .sensor_count = 2,
|
|
+ .supports_nvmem = false,
|
|
+ .support_irq = true,
|
|
+ .ctrl0_map = SUNXI_THS_ACQ0(0x1f3),
|
|
+ .ctrl2_map = SUNXI_THS_ACQ1(0x1f3),
|
|
+ .sensor_en_map = SUNXI_THS_TEMP_SENSE_EN0 |
|
|
+ SUNXI_THS_TEMP_SENSE_EN1,
|
|
+ .filter_map = SUNXI_THS_FILTER_EN |
|
|
+ SUNXI_THS_FILTER_TYPE(0x2),
|
|
+ .irq_clear_map = SUNXI_THS_INTS_ALARM_INT_0 |
|
|
+ SUNXI_THS_INTS_ALARM_INT_1 |
|
|
+ SUNXI_THS_INTS_SHUT_INT_0 |
|
|
+ SUNXI_THS_INTS_SHUT_INT_1 |
|
|
+ SUNXI_THS_INTS_TDATA_IRQ_0 |
|
|
+ SUNXI_THS_INTS_TDATA_IRQ_1 |
|
|
+ SUNXI_THS_INTS_ALARM_OFF_0 |
|
|
+ SUNXI_THS_INTS_ALARM_OFF_1,
|
|
+ .irq_control_map = SUNXI_THS_INTC_TDATA_IRQ_EN0 |
|
|
+ SUNXI_THS_INTC_TDATA_IRQ_EN1 |
|
|
+ SUNXI_THS_TEMP_PERIOD(0x3a),
|
|
+};
|
|
+
|
|
struct sun4i_gpadc_iio {
|
|
struct iio_dev *indio_dev;
|
|
struct completion completion;
|
|
@@ -710,6 +742,10 @@ static const struct of_device_id sun4i_gpadc_of_id[] = {
|
|
.compatible = "allwinner,sun8i-a83t-ths",
|
|
.data = &sun8i_a83t_ths_data,
|
|
},
|
|
+ {
|
|
+ .compatible = "allwinner,sun50i-h5-ths",
|
|
+ .data = &sun50i_h5_ths_data,
|
|
+ },
|
|
{ /* sentinel */ }
|
|
};
|
|
|
|
--
|
|
2.17.1
|
|
|