
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
46 lines
1.2 KiB
Text
46 lines
1.2 KiB
Text
From 5bcffafbbcc98a66101d02d37ba6beca3f52068e Mon Sep 17 00:00:00 2001
|
|
From: Philipp Rossak <embed3d@gmail.com>
|
|
Date: Fri, 26 Jan 2018 01:17:14 +0100
|
|
Subject: [PATCH 024/146] arm: dts: sun8i: a83t: add thermal zone to A83T
|
|
|
|
This patch adds the thermal zones to the A83T. Sensor 0 is located in the
|
|
cpu cluster 0. Sensor 1 is located in cluster 1 and Sensor 3 is located
|
|
in the gpu.
|
|
|
|
Signed-off-by: Philipp Rossak <embed3d@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/sun8i-a83t.dtsi | 20 ++++++++++++++++++++
|
|
1 file changed, 20 insertions(+)
|
|
|
|
diff --git a/arch/arm/boot/dts/sun8i-a83t.dtsi b/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
index 6bdfcc7a1ac3..ec22157419b6 100644
|
|
--- a/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
+++ b/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
@@ -1033,4 +1033,24 @@
|
|
#size-cells = <0>;
|
|
};
|
|
};
|
|
+
|
|
+ thermal-zones {
|
|
+ cpu0_thermal: cpu0-thermal {
|
|
+ polling-delay-passive = <1000>;
|
|
+ polling-delay = <5000>;
|
|
+ thermal-sensors = <&ths 0>;
|
|
+ };
|
|
+
|
|
+ cpu1_thermal: cpu1-thermal {
|
|
+ polling-delay-passive = <1000>;
|
|
+ polling-delay = <5000>;
|
|
+ thermal-sensors = <&ths 1>;
|
|
+ };
|
|
+
|
|
+ gpu_thermal: gpu-thermal {
|
|
+ polling-delay-passive = <1000>;
|
|
+ polling-delay = <5000>;
|
|
+ thermal-sensors = <&ths 2>;
|
|
+ };
|
|
+ };
|
|
};
|
|
--
|
|
2.17.1
|
|
|