
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
38 lines
1.1 KiB
Text
38 lines
1.1 KiB
Text
From 4d9df1fab6b1601612b7b4380f83d3c4560c671e Mon Sep 17 00:00:00 2001
|
|
From: Philipp Rossak <embed3d@gmail.com>
|
|
Date: Fri, 26 Jan 2018 01:15:17 +0100
|
|
Subject: [PATCH 023/146] arm: dts: sun8i: a83t: add support for the thermal
|
|
sensor in A83T
|
|
|
|
As we have gained the support for the thermal sensor in A83T,
|
|
we can now add its device nodes to the device tree.
|
|
|
|
The A83T seems to have a broken IRQ 31, thus we use here IRQ 41.
|
|
|
|
Signed-off-by: Philipp Rossak <embed3d@gmail.com>
|
|
---
|
|
arch/arm/boot/dts/sun8i-a83t.dtsi | 8 ++++++++
|
|
1 file changed, 8 insertions(+)
|
|
|
|
diff --git a/arch/arm/boot/dts/sun8i-a83t.dtsi b/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
index 00a02b037320..6bdfcc7a1ac3 100644
|
|
--- a/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
+++ b/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
@@ -757,6 +757,14 @@
|
|
clocks = <&osc24M>;
|
|
};
|
|
|
|
+ ths: thermal-sensor@1f04000 {
|
|
+ compatible = "allwinner,sun8i-a83t-ths";
|
|
+ reg = <0x01f04000 0x100>;
|
|
+ interrupts = <GIC_SPI 41 IRQ_TYPE_LEVEL_HIGH>;
|
|
+ #thermal-sensor-cells = <1>;
|
|
+ #io-channel-cells = <0>;
|
|
+ };
|
|
+
|
|
watchdog@1c20ca0 {
|
|
compatible = "allwinner,sun6i-a31-wdt";
|
|
reg = <0x01c20ca0 0x20>;
|
|
--
|
|
2.17.1
|
|
|