balena-allwinner/layers/meta-balena-allwinner/recipes-bsp/u-boot/u-boot_2017.11/0003-libftd_fix.patch
Vicentiu Galanopulo a6f018156d u-boot_2017.11.bb: Add patch to fix conflicting types for fdt64_t
When libfdt-devel is installed system-wide, the build of U-Boot host
programs currently fails with lots of:

In file included from tools/../include/../lib/libfdt/libfdt.h:10:0,
                 from tools/../include/libfdt.h:1,
                 from tools/fdt_host.h:11,
                 from tools/imagetool.h:24,
                 from tools/aisimage.c:8:
/usr/include/libfdt_env.h:70:30: error: conflicting types for ‘fdt64_t’
   typedef uint64_t FDT_BITWISE fdt64_t;
                               ^~~~~~~
In file included from <command-line>:0:0:
././include/libfdt_env.h:19:16: note: previous declaration of ‘fdt64_t’ was here
   typedef __be64 fdt64_t;
                 ^~~~~~~
In file included from ././include/libfdt_env.h:12:0,
                  from <command-line>:0:
/usr/include/libfdt_env.h:90:24: error: expected ‘)’ before ‘x’
    static inline uint32_t fdt32_to_cpu(fdt32_t x)
                         ^

This commit adds a fixup in the U-Boot code to fix this problem

Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
2019-10-10 11:50:43 +02:00

35 lines
1.1 KiB
Diff

From 6eecc74a9178ddd29375a6c3ee354f2e8b989c45 Mon Sep 17 00:00:00 2001
From: Vicentiu Galanopulo <vicentiu@balena.io>
Date: Thu, 26 Sep 2019 16:19:02 +0200
Subject: [PATCH] Include U-Boot libfdt headers from their actual path
There are no headers for libfdt in lib/libfdt, as they are instead
located in scripts/dtc/libfdt. Specifying lib/libfdt for headers
inclusion in host tools results in using the system libfdt headers,
which is not what we want. Change this to the proper path.
Signed-off-by:Paul Kocialkowski <contact@paulk.fr>
Upstream-Status: Inappropriate [Backport]
Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
---
tools/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/Makefile b/tools/Makefile
index 54bd22406a..39ccbaa881 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -266,7 +266,7 @@ endif # !LOGO_BMP
#
HOST_EXTRACFLAGS += -include $(srctree)/include/libfdt_env.h \
$(patsubst -I%,-idirafter%, $(filter -I%, $(UBOOTINCLUDE))) \
- -I$(srctree)/lib/libfdt \
+ -I$(srctree)/scripts/dtc/libfdt \
-I$(srctree)/tools \
-DUSE_HOSTCC \
-D__KERNEL_STRICT_NAMES \
--
2.17.1