
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
70 lines
1.4 KiB
Diff
70 lines
1.4 KiB
Diff
From 46ea76edb4c37e99f1cc2b2b75c80841467f6f3b Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <icenowy@aosc.io>
|
|
Date: Fri, 5 Jan 2018 18:35:04 +0800
|
|
Subject: [PATCH 28/35] arm64: allwinner: h6: enable USB2 on Pine H64
|
|
|
|
Pine H64 board has both the USB2 OTG port and the USB2 host port on H6
|
|
SoC wired out to USB Type-A port.
|
|
|
|
Enable them.
|
|
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
.../boot/dts/allwinner/sun50i-h6-pine-h64.dts | 27 ++++++++++++++++++++++
|
|
1 file changed, 27 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h6-pine-h64.dts b/arch/arm64/boot/dts/allwinner/sun50i-h6-pine-h64.dts
|
|
index acfa90e..038e213 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h6-pine-h64.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h6-pine-h64.dts
|
|
@@ -51,6 +51,14 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+&ehci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ehci3 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&mmc0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&mmc0_pins>;
|
|
@@ -69,6 +77,14 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+&ohci0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&ohci3 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&r_i2c {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&r_i2c_pins>;
|
|
@@ -195,6 +211,17 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+&usb2otg {
|
|
+ dr_mode = "host";
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&usb2phy {
|
|
+ usb0_vbus-supply = <®_usb_vbus>;
|
|
+ usb3_vbus-supply = <®_usb_vbus>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&usb3 {
|
|
status = "okay";
|
|
};
|
|
--
|
|
2.7.4
|
|
|