
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
84 lines
1.9 KiB
Diff
84 lines
1.9 KiB
Diff
From 82fe5562e8d5cb289e97ff8d259b21889e72b03b Mon Sep 17 00:00:00 2001
|
|
From: Icenowy Zheng <icenowy@aosc.io>
|
|
Date: Thu, 18 Oct 2018 15:33:25 +0800
|
|
Subject: [PATCH 132/146] arm64: allwinner: a64: enable ANX6345 bridge on
|
|
Pinebook
|
|
|
|
Pinebook has an ANX6345 bridge connected to the RGB666 LCD output, and
|
|
the I2C controlling signals are connected to R_I2C bus.
|
|
|
|
Enable it in the device tree, and add a usable EDID from the panel's
|
|
datasheet (at least 14" Pinebook used a panel without EDID).
|
|
|
|
Signed-off-by: Icenowy Zheng <icenowy@aosc.io>
|
|
---
|
|
.../dts/allwinner/sun50i-a64-pinebook.dts | 39 +++++++++++++++++++
|
|
1 file changed, 39 insertions(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts b/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts
|
|
index b55ac4e1df37..8c9bd4dfbbba 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-pinebook.dts
|
|
@@ -123,6 +123,10 @@
|
|
};
|
|
};
|
|
|
|
+&mixer0 {
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&mmc0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&mmc0_pins>;
|
|
@@ -175,6 +179,27 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+&r_i2c {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&r_i2c_pins_a>;
|
|
+ status = "okay";
|
|
+
|
|
+ anx6345: anx6345@38 {
|
|
+ compatible = "analogix,anx6345";
|
|
+ reg = <0x38>;
|
|
+ reset-gpios = <&pio 3 24 GPIO_ACTIVE_HIGH>; /* PD24 */
|
|
+ panel-supply = <®_dc1sw>;
|
|
+ dvdd25-supply = <®_dldo2>;
|
|
+ dvdd12-supply = <®_fldo1>;
|
|
+
|
|
+ port {
|
|
+ anx6345_in: endpoint {
|
|
+ remote-endpoint = <&tcon0_out_anx6345>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|
|
+
|
|
&r_rsb {
|
|
status = "okay";
|
|
|
|
@@ -348,6 +373,20 @@
|
|
"MIC2", "Internal Microphone Right";
|
|
};
|
|
|
|
+&tcon0 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&lcd_rgb666_pins>;
|
|
+
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
+&tcon0_out {
|
|
+ tcon0_out_anx6345: endpoint@0 {
|
|
+ reg = <0>;
|
|
+ remote-endpoint = <&anx6345_in>;
|
|
+ };
|
|
+};
|
|
+
|
|
&uart0 {
|
|
pinctrl-names = "default";
|
|
pinctrl-0 = <&uart0_pins_a>;
|
|
--
|
|
2.17.1
|
|
|