
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
30 lines
1,000 B
Diff
30 lines
1,000 B
Diff
From aab02e1c386fa2ab761aea583b59ce72824f70c4 Mon Sep 17 00:00:00 2001
|
|
From: Jernej Skrabec <jernej.skrabec@siol.net>
|
|
Date: Thu, 8 Mar 2018 17:21:29 +0100
|
|
Subject: [PATCH 78/82] drm/sun4i: Enable auto_cts quirk for DW HDMI
|
|
|
|
Allwinner SoCs with DW HDMI don't output any sound if auto CTS option is
|
|
not enabled.
|
|
|
|
Enable it.
|
|
|
|
Signed-off-by: Jernej Skrabec <jernej.skrabec@siol.net>
|
|
---
|
|
drivers/gpu/drm/sun4i/sun8i_dw_hdmi.c | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/drivers/gpu/drm/sun4i/sun8i_dw_hdmi.c b/drivers/gpu/drm/sun4i/sun8i_dw_hdmi.c
|
|
index 31875b636434..9aaec57f7441 100644
|
|
--- a/drivers/gpu/drm/sun4i/sun8i_dw_hdmi.c
|
|
+++ b/drivers/gpu/drm/sun4i/sun8i_dw_hdmi.c
|
|
@@ -156,6 +156,7 @@ static int sun8i_dw_hdmi_bind(struct device *dev, struct device *master,
|
|
|
|
sun8i_hdmi_phy_init(hdmi->phy);
|
|
|
|
+ plat_data->auto_cts = true;
|
|
plat_data->mode_valid = &sun8i_dw_hdmi_mode_valid;
|
|
plat_data->phy_ops = sun8i_hdmi_phy_get_ops();
|
|
plat_data->phy_name = "sun8i_dw_hdmi_phy";
|
|
--
|
|
2.20.1
|
|
|