
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
54 lines
1.7 KiB
Diff
54 lines
1.7 KiB
Diff
From dc476b21de3ab98df3b94514d995bf4fc0fa0db4 Mon Sep 17 00:00:00 2001
|
|
From: Ondrej Jirman <megous@megous.com>
|
|
Date: Fri, 18 Aug 2017 13:55:48 +0200
|
|
Subject: [PATCH 75/82] Make microbuttons on Orange Pi PC and PC 2 work as
|
|
power off buttons
|
|
|
|
---
|
|
arch/arm/boot/dts/sun8i-h3-orangepi-one.dts | 2 +-
|
|
arch/arm/boot/dts/sun8i-h3-orangepi-pc.dts | 2 +-
|
|
arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-pc2.dts | 2 +-
|
|
3 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/arch/arm/boot/dts/sun8i-h3-orangepi-one.dts b/arch/arm/boot/dts/sun8i-h3-orangepi-one.dts
|
|
index 245fd658defb..a30c4fae5466 100644
|
|
--- a/arch/arm/boot/dts/sun8i-h3-orangepi-one.dts
|
|
+++ b/arch/arm/boot/dts/sun8i-h3-orangepi-one.dts
|
|
@@ -95,7 +95,7 @@
|
|
|
|
sw4 {
|
|
label = "sw4";
|
|
- linux,code = <BTN_0>;
|
|
+ linux,code = <KEY_POWER>;
|
|
gpios = <&r_pio 0 3 GPIO_ACTIVE_LOW>;
|
|
};
|
|
};
|
|
diff --git a/arch/arm/boot/dts/sun8i-h3-orangepi-pc.dts b/arch/arm/boot/dts/sun8i-h3-orangepi-pc.dts
|
|
index 83f1866ed9e7..056cb587f3c0 100644
|
|
--- a/arch/arm/boot/dts/sun8i-h3-orangepi-pc.dts
|
|
+++ b/arch/arm/boot/dts/sun8i-h3-orangepi-pc.dts
|
|
@@ -95,7 +95,7 @@
|
|
|
|
sw4 {
|
|
label = "sw4";
|
|
- linux,code = <BTN_0>;
|
|
+ linux,code = <KEY_POWER>;
|
|
gpios = <&r_pio 0 3 GPIO_ACTIVE_LOW>;
|
|
};
|
|
};
|
|
diff --git a/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-pc2.dts b/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-pc2.dts
|
|
index af8e3fe26e20..4846d76dd908 100644
|
|
--- a/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-pc2.dts
|
|
+++ b/arch/arm64/boot/dts/allwinner/sun50i-h5-orangepi-pc2.dts
|
|
@@ -98,7 +98,7 @@
|
|
|
|
sw4 {
|
|
label = "sw4";
|
|
- linux,code = <BTN_0>;
|
|
+ linux,code = <KEY_POWER>;
|
|
gpios = <&r_pio 0 3 GPIO_ACTIVE_LOW>;
|
|
};
|
|
};
|
|
--
|
|
2.20.1
|
|
|