
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
84 lines
2 KiB
Diff
84 lines
2 KiB
Diff
From 6352f285dc5071be981ac30d72b4fbd11bed7fcd Mon Sep 17 00:00:00 2001
|
|
From: Ondrej Jirman <megous@megous.com>
|
|
Date: Sat, 30 Jun 2018 07:58:54 +0200
|
|
Subject: [PATCH 72/82] ARM: dts: sun8i-a83t: Add missing cooling-cells
|
|
properties to cpu nodes
|
|
|
|
Signed-off-by: Ondrej Jirman <megous@megous.com>
|
|
---
|
|
arch/arm/boot/dts/sun8i-a83t.dtsi | 10 ++++++----
|
|
1 file changed, 6 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/arch/arm/boot/dts/sun8i-a83t.dtsi b/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
index 17371e0614e2..cb0607580d04 100644
|
|
--- a/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
+++ b/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
@@ -72,8 +72,6 @@
|
|
enable-method = "allwinner,sun8i-a83t-smp";
|
|
reg = <0>;
|
|
#cooling-cells = <2>;
|
|
- cooling-min-level = <0>;
|
|
- cooling-max-level = <7>;
|
|
};
|
|
|
|
cpu@1 {
|
|
@@ -86,6 +84,7 @@
|
|
cci-control-port = <&cci_control0>;
|
|
enable-method = "allwinner,sun8i-a83t-smp";
|
|
reg = <1>;
|
|
+ #cooling-cells = <2>;
|
|
};
|
|
|
|
cpu@2 {
|
|
@@ -98,6 +97,7 @@
|
|
cci-control-port = <&cci_control0>;
|
|
enable-method = "allwinner,sun8i-a83t-smp";
|
|
reg = <2>;
|
|
+ #cooling-cells = <2>;
|
|
};
|
|
|
|
cpu@3 {
|
|
@@ -110,6 +110,7 @@
|
|
cci-control-port = <&cci_control0>;
|
|
enable-method = "allwinner,sun8i-a83t-smp";
|
|
reg = <3>;
|
|
+ #cooling-cells = <2>;
|
|
};
|
|
|
|
cpu100: cpu@100 {
|
|
@@ -123,8 +124,6 @@
|
|
enable-method = "allwinner,sun8i-a83t-smp";
|
|
reg = <0x100>;
|
|
#cooling-cells = <2>;
|
|
- cooling-min-level = <0>;
|
|
- cooling-max-level = <7>;
|
|
};
|
|
|
|
cpu@101 {
|
|
@@ -137,6 +136,7 @@
|
|
cci-control-port = <&cci_control1>;
|
|
enable-method = "allwinner,sun8i-a83t-smp";
|
|
reg = <0x101>;
|
|
+ #cooling-cells = <2>;
|
|
};
|
|
|
|
cpu@102 {
|
|
@@ -149,6 +149,7 @@
|
|
cci-control-port = <&cci_control1>;
|
|
enable-method = "allwinner,sun8i-a83t-smp";
|
|
reg = <0x102>;
|
|
+ #cooling-cells = <2>;
|
|
};
|
|
|
|
cpu@103 {
|
|
@@ -161,6 +162,7 @@
|
|
cci-control-port = <&cci_control1>;
|
|
enable-method = "allwinner,sun8i-a83t-smp";
|
|
reg = <0x103>;
|
|
+ #cooling-cells = <2>;
|
|
};
|
|
};
|
|
|
|
--
|
|
2.20.1
|
|
|