
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
72 lines
1.7 KiB
Diff
72 lines
1.7 KiB
Diff
From 3bfe739a6da69c2a51dbd6d4288975bedaee04f8 Mon Sep 17 00:00:00 2001
|
|
From: Ondrej Jirman <megous@megous.com>
|
|
Date: Sat, 30 Jun 2018 07:58:15 +0200
|
|
Subject: [PATCH 71/82] ARM: dts: sun8i-a83t: Add missing clock properties to
|
|
cpu nodes
|
|
|
|
Signed-off-by: Ondrej Jirman <megous@megous.com>
|
|
---
|
|
arch/arm/boot/dts/sun8i-a83t.dtsi | 12 ++++++++++++
|
|
1 file changed, 12 insertions(+)
|
|
|
|
diff --git a/arch/arm/boot/dts/sun8i-a83t.dtsi b/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
index c09d8ee2f7c5..17371e0614e2 100644
|
|
--- a/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
+++ b/arch/arm/boot/dts/sun8i-a83t.dtsi
|
|
@@ -77,6 +77,8 @@
|
|
};
|
|
|
|
cpu@1 {
|
|
+ clocks = <&ccu CLK_C0CPUX>;
|
|
+ clock-names = "cpu";
|
|
compatible = "arm,cortex-a7";
|
|
clock-frequency = <1200000000>;
|
|
device_type = "cpu";
|
|
@@ -87,6 +89,8 @@
|
|
};
|
|
|
|
cpu@2 {
|
|
+ clocks = <&ccu CLK_C0CPUX>;
|
|
+ clock-names = "cpu";
|
|
compatible = "arm,cortex-a7";
|
|
clock-frequency = <1200000000>;
|
|
device_type = "cpu";
|
|
@@ -97,6 +101,8 @@
|
|
};
|
|
|
|
cpu@3 {
|
|
+ clocks = <&ccu CLK_C0CPUX>;
|
|
+ clock-names = "cpu";
|
|
compatible = "arm,cortex-a7";
|
|
clock-frequency = <1200000000>;
|
|
device_type = "cpu";
|
|
@@ -122,6 +128,8 @@
|
|
};
|
|
|
|
cpu@101 {
|
|
+ clocks = <&ccu CLK_C1CPUX>;
|
|
+ clock-names = "cpu";
|
|
compatible = "arm,cortex-a7";
|
|
clock-frequency = <1200000000>;
|
|
device_type = "cpu";
|
|
@@ -132,6 +140,8 @@
|
|
};
|
|
|
|
cpu@102 {
|
|
+ clocks = <&ccu CLK_C1CPUX>;
|
|
+ clock-names = "cpu";
|
|
compatible = "arm,cortex-a7";
|
|
clock-frequency = <1200000000>;
|
|
device_type = "cpu";
|
|
@@ -142,6 +152,8 @@
|
|
};
|
|
|
|
cpu@103 {
|
|
+ clocks = <&ccu CLK_C1CPUX>;
|
|
+ clock-names = "cpu";
|
|
compatible = "arm,cortex-a7";
|
|
clock-frequency = <1200000000>;
|
|
device_type = "cpu";
|
|
--
|
|
2.20.1
|
|
|