
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
65 lines
1.6 KiB
Diff
65 lines
1.6 KiB
Diff
From 9e45d6dd4dfcc8706081ee992b24acab372d845a Mon Sep 17 00:00:00 2001
|
|
From: Ondrej Jirman <megous@megous.com>
|
|
Date: Fri, 10 Nov 2017 22:24:15 +0100
|
|
Subject: [PATCH 51/82] ARM: dts: sun8i-a83t-tbs-a711: Enable uart2 and add gps
|
|
regulator
|
|
|
|
Now we can use tbs-a711 driver for power/reset control for GPS module.
|
|
Enable this. This allows access to u-blox NEO-6M connected to uart2.
|
|
|
|
Signed-off-by: Ondrej Jirman <megous@megous.com>
|
|
---
|
|
arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts | 23 +++++++++++++++++++++++
|
|
1 file changed, 23 insertions(+)
|
|
|
|
diff --git a/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts b/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts
|
|
index ab4dce4b1e67..b0a94cf13740 100644
|
|
--- a/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts
|
|
+++ b/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts
|
|
@@ -121,6 +121,15 @@
|
|
};
|
|
};
|
|
|
|
+ reg_gps: reg-gps {
|
|
+ compatible = "regulator-fixed";
|
|
+ regulator-name = "gps";
|
|
+ regulator-min-microvolt = <3000000>;
|
|
+ regulator-max-microvolt = <3000000>;
|
|
+ enable-active-high;
|
|
+ gpio = <&pio 3 4 GPIO_ACTIVE_HIGH>; /* PD4 */
|
|
+ };
|
|
+
|
|
reg_vbat: reg-vbat {
|
|
compatible = "regulator-fixed";
|
|
regulator-name = "vbat";
|
|
@@ -149,6 +158,13 @@
|
|
clocks = <&ac100_rtc 1>;
|
|
clock-names = "ext_clock";
|
|
};
|
|
+
|
|
+ gps {
|
|
+ compatible = "custom,power-manager";
|
|
+ power-supply = <®_gps>;
|
|
+ reset-duration-ms = <5>;
|
|
+ char-device-name = "pwr-gps";
|
|
+ };
|
|
};
|
|
|
|
&cpu0 {
|
|
@@ -564,6 +580,13 @@
|
|
status = "okay";
|
|
};
|
|
|
|
+/* GPS NEO-6M */
|
|
+&uart2 {
|
|
+ pinctrl-names = "default";
|
|
+ pinctrl-0 = <&uart2_pb_pins>;
|
|
+ status = "okay";
|
|
+};
|
|
+
|
|
&usb_otg {
|
|
dr_mode = "otg";
|
|
status = "okay";
|
|
--
|
|
2.20.1
|
|
|