
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
52 lines
1.2 KiB
Diff
52 lines
1.2 KiB
Diff
From 8c120e82a6cd86742dbdfd5c0a17d88737a74394 Mon Sep 17 00:00:00 2001
|
|
From: Ondrej Jirman <megous@megous.com>
|
|
Date: Sun, 12 Nov 2017 06:25:59 +0100
|
|
Subject: [PATCH 47/82] ARM: dts: sun8i-a83t-tbs-a711: Add support for volume
|
|
keys input
|
|
|
|
Signed-off-by: Ondrej Jirman <megous@megous.com>
|
|
---
|
|
arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts | 20 ++++++++++++++++++++
|
|
1 file changed, 20 insertions(+)
|
|
|
|
diff --git a/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts b/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts
|
|
index 787277f4d455..ab4dce4b1e67 100644
|
|
--- a/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts
|
|
+++ b/arch/arm/boot/dts/sun8i-a83t-tbs-a711.dts
|
|
@@ -46,6 +46,7 @@
|
|
|
|
#include <dt-bindings/gpio/gpio.h>
|
|
#include <dt-bindings/pwm/pwm.h>
|
|
+#include <dt-bindings/input/input.h>
|
|
|
|
/ {
|
|
model = "TBS A711 Tablet";
|
|
@@ -289,6 +290,25 @@
|
|
};
|
|
};
|
|
|
|
+&lradc {
|
|
+ vref-supply = <®_aldo2>;
|
|
+ status = "okay";
|
|
+
|
|
+ button@200 {
|
|
+ label = "Volume Up";
|
|
+ linux,code = <KEY_VOLUMEUP>;
|
|
+ channel = <0>;
|
|
+ voltage = <210000>;
|
|
+ };
|
|
+
|
|
+ button@400 {
|
|
+ label = "Volume Down";
|
|
+ linux,code = <KEY_VOLUMEDOWN>;
|
|
+ channel = <0>;
|
|
+ voltage = <410000>;
|
|
+ };
|
|
+};
|
|
+
|
|
&mmc0 {
|
|
vmmc-supply = <®_dcdc1>;
|
|
pinctrl-names = "default";
|
|
--
|
|
2.20.1
|
|
|