
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
71 lines
2.3 KiB
Diff
71 lines
2.3 KiB
Diff
From 086f56910cfcc26939c56dfd143c7ee3dc24cff1 Mon Sep 17 00:00:00 2001
|
|
From: Ondrej Jirman <megous@megous.com>
|
|
Date: Sat, 30 Sep 2017 02:30:39 +0200
|
|
Subject: [PATCH 30/82] media: dt-bindings: Add bindings for Himax HM5065
|
|
camera sensor
|
|
|
|
HM5065 is 5MP CMOS sensor...
|
|
|
|
Signed-off-by: Ondrej Jirman <megous@megous.com>
|
|
---
|
|
.../devicetree/bindings/media/i2c/hm5065.txt | 48 +++++++++++++++++++
|
|
1 file changed, 48 insertions(+)
|
|
create mode 100644 Documentation/devicetree/bindings/media/i2c/hm5065.txt
|
|
|
|
diff --git a/Documentation/devicetree/bindings/media/i2c/hm5065.txt b/Documentation/devicetree/bindings/media/i2c/hm5065.txt
|
|
new file mode 100644
|
|
index 000000000000..68ad7f529e18
|
|
--- /dev/null
|
|
+++ b/Documentation/devicetree/bindings/media/i2c/hm5065.txt
|
|
@@ -0,0 +1,48 @@
|
|
+* Himax HM5065 CSI camera sensor
|
|
+
|
|
+Required Properties:
|
|
+- compatible: should be "himax,hm5065"
|
|
+- clocks: reference to the external input clock for the sensor.
|
|
+- clock-names: should be "xclk".
|
|
+- IOVDD-supply: Digital I/O voltage supply, 2.8 volts
|
|
+- AVDD-supply: Analog voltage supply, 2.8 volts
|
|
+- DVDD-supply: Digital core voltage supply, 1.8 volts
|
|
+- AFVDD-supply: Auto focus voltage supply, 2.8 volts
|
|
+
|
|
+Optional Properties (one or both must be configured):
|
|
+- reset-gpios: reference to the GPIO connected to the reset pin, if any.
|
|
+ This is an active low signal to the HM5065.
|
|
+- chipenable-gpios: reference to the GPIO connected to the CE pin,
|
|
+ if any. This is an active high signal to the HM5065.
|
|
+
|
|
+The device node must contain one 'port' child node for its digital output
|
|
+video port, in accordance with the video interface bindings defined in
|
|
+Documentation/devicetree/bindings/media/video-interfaces.txt.
|
|
+
|
|
+Example:
|
|
+
|
|
+&i2c1 {
|
|
+ hm5065: camera@1f {
|
|
+ compatible = "himax,hm5065";
|
|
+ reg = <0x1f>;
|
|
+ clocks = <&ccu CLK_CSI_MCLK>;
|
|
+ clock-names = "xclk";
|
|
+ IOVDD-supply = <®_dldo3>;
|
|
+ AVDD-supply = <®_dldo4>;
|
|
+ DVDD-supply = <®_eldo3>;
|
|
+ AFVDD-supply = <®_dldo3>;
|
|
+ reset-gpios = <&pio 4 18 GPIO_ACTIVE_LOW>; /* PE18 */
|
|
+ chipenable-gpios = <&pio 4 19 GPIO_ACTIVE_HIGH>; /* PE19 */
|
|
+
|
|
+ port {
|
|
+ hm5065_ep: endpoint {
|
|
+ remote-endpoint = <&csi0_hm5065_ep>;
|
|
+ bus-width = <8>;
|
|
+ hsync-active = <1>;
|
|
+ vsync-active = <1>;
|
|
+ data-active = <1>;
|
|
+ pclk-sample = <1>;
|
|
+ };
|
|
+ };
|
|
+ };
|
|
+};
|
|
--
|
|
2.20.1
|
|
|