
Some patches were part of other linux-mainline kernel versions but are not anymore part of the current 4.19.76. Move 0001-Enable-uart3-for-NanoPi-Neo-Air-used-by-BT.patch in linux-mainline_4.19.76.bbappend to avoid error patching file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Hunk #2 FAILED at 162. 1 out of 2 hunks FAILED -- rejects in file arch/arm/boot/dts/sun8i-h3-nanopi-neo-air.dts Place all patches from Armbian in a separate directory and do all the Balena specific operations in linux-mainline_%.bbappend only. Changelog-entry: Remove unused patches and cleanup Signed-off-by: Vicentiu Galanopulo <vicentiu@balena.io>
85 lines
2.3 KiB
Diff
85 lines
2.3 KiB
Diff
From d4028daf51824eb792fb3c9cc77553ff1edc5d68 Mon Sep 17 00:00:00 2001
|
|
From: Ondrej Jirman <megous@megous.com>
|
|
Date: Mon, 14 May 2018 00:56:50 +0200
|
|
Subject: [PATCH 12/82] ARM: dts: sunxi-h3-h5: Move CPU OPP table to dtsi
|
|
shared by H3/H5
|
|
|
|
It is identical for H3 and H5, so it better live there.
|
|
|
|
Signed-off-by: Ondrej Jirman <megous@megous.com>
|
|
---
|
|
arch/arm/boot/dts/sun8i-h3.dtsi | 23 -----------------------
|
|
arch/arm/boot/dts/sunxi-h3-h5.dtsi | 23 +++++++++++++++++++++++
|
|
2 files changed, 23 insertions(+), 23 deletions(-)
|
|
|
|
diff --git a/arch/arm/boot/dts/sun8i-h3.dtsi b/arch/arm/boot/dts/sun8i-h3.dtsi
|
|
index cb19ff797606..261ca0356358 100644
|
|
--- a/arch/arm/boot/dts/sun8i-h3.dtsi
|
|
+++ b/arch/arm/boot/dts/sun8i-h3.dtsi
|
|
@@ -43,29 +43,6 @@
|
|
#include "sunxi-h3-h5.dtsi"
|
|
|
|
/ {
|
|
- cpu0_opp_table: opp_table0 {
|
|
- compatible = "operating-points-v2";
|
|
- opp-shared;
|
|
-
|
|
- opp@648000000 {
|
|
- opp-hz = /bits/ 64 <648000000>;
|
|
- opp-microvolt = <1040000 1040000 1300000>;
|
|
- clock-latency-ns = <244144>; /* 8 32k periods */
|
|
- };
|
|
-
|
|
- opp@816000000 {
|
|
- opp-hz = /bits/ 64 <816000000>;
|
|
- opp-microvolt = <1100000 1100000 1300000>;
|
|
- clock-latency-ns = <244144>; /* 8 32k periods */
|
|
- };
|
|
-
|
|
- opp@1008000000 {
|
|
- opp-hz = /bits/ 64 <1008000000>;
|
|
- opp-microvolt = <1200000 1200000 1300000>;
|
|
- clock-latency-ns = <244144>; /* 8 32k periods */
|
|
- };
|
|
- };
|
|
-
|
|
cpus {
|
|
#address-cells = <1>;
|
|
#size-cells = <0>;
|
|
diff --git a/arch/arm/boot/dts/sunxi-h3-h5.dtsi b/arch/arm/boot/dts/sunxi-h3-h5.dtsi
|
|
index 13fe5e316136..539b69fecbe9 100644
|
|
--- a/arch/arm/boot/dts/sunxi-h3-h5.dtsi
|
|
+++ b/arch/arm/boot/dts/sunxi-h3-h5.dtsi
|
|
@@ -105,6 +105,29 @@
|
|
};
|
|
};
|
|
|
|
+ cpu0_opp_table: opp_table0 {
|
|
+ compatible = "operating-points-v2";
|
|
+ opp-shared;
|
|
+
|
|
+ opp@648000000 {
|
|
+ opp-hz = /bits/ 64 <648000000>;
|
|
+ opp-microvolt = <1040000 1040000 1300000>;
|
|
+ clock-latency-ns = <244144>; /* 8 32k periods */
|
|
+ };
|
|
+
|
|
+ opp@816000000 {
|
|
+ opp-hz = /bits/ 64 <816000000>;
|
|
+ opp-microvolt = <1100000 1100000 1300000>;
|
|
+ clock-latency-ns = <244144>; /* 8 32k periods */
|
|
+ };
|
|
+
|
|
+ opp@1008000000 {
|
|
+ opp-hz = /bits/ 64 <1008000000>;
|
|
+ opp-microvolt = <1200000 1200000 1300000>;
|
|
+ clock-latency-ns = <244144>; /* 8 32k periods */
|
|
+ };
|
|
+ };
|
|
+
|
|
de: display-engine {
|
|
compatible = "allwinner,sun8i-h3-display-engine";
|
|
allwinner,pipelines = <&mixer0>;
|
|
--
|
|
2.20.1
|
|
|